summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 9db150c905..7ff4c217a3 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -130,6 +130,10 @@ define Build/pad-to
mv $@.new $@
endef
+define Build/pad-extra
+ dd if=/dev/zero bs=$(1) count=1 >> $@
+endef
+
define Build/pad-rootfs
$(STAGING_DIR_HOST)/bin/padjffs2 $@ $(1) \
$(if $(BLOCKSIZE),$(BLOCKSIZE:%k=%),4 8 16 64 128 256)