summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 40a9619c31..3b9ea3ccba 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -137,8 +137,8 @@ endef
define Build/pad-offset
let \
size="$$(stat -c%s $@)" \
- pad="$(word 1, $(1))" \
- offset="$(word 2, $(1))" \
+ pad="$(subst k,* 1024,$(word 1, $(1)))" \
+ offset="$(subst k,* 1024,$(word 2, $(1)))" \
pad="(pad - ((size + offset) % pad)) % pad" \
newsize='size + pad'; \
dd if=$@ of=$@.new bs=$$newsize count=1 conv=sync