summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk1
-rw-r--r--include/image.mk3
2 files changed, 3 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 00cb3410e9..40a9619c31 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -114,6 +114,7 @@ define Build/append-ubi
sh $(TOPDIR)/scripts/ubinize-image.sh \
$(if $(UBOOTENV_IN_UBI),--uboot-env) \
$(if $(KERNEL_IN_UBI),--kernel $(IMAGE_KERNEL)) \
+ $(foreach part,$(UBINIZE_PARTS),--part $(part)) \
$(IMAGE_ROOTFS) \
$@.tmp \
-p $(BLOCKSIZE) -m $(PAGESIZE) \
diff --git a/include/image.mk b/include/image.mk
index c85a9d6505..7079f18786 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -347,6 +347,7 @@ define Device/Init
SUBPAGESIZE :=
VID_HDR_OFFSET :=
UBINIZE_OPTS := -E 5
+ UBINIZE_PARTS :=
MKUBIFS_OPTS :=
FS_OPTIONS/ubifs = $$(MKUBIFS_OPTS)
@@ -365,7 +366,7 @@ DEFAULT_DEVICE_VARS := \
DEVICE_DTS DEVICE_DTS_DIR BOARD_NAME CMDLINE \
UBOOTENV_IN_UBI KERNEL_IN_UBI \
BLOCKSIZE PAGESIZE SUBPAGESIZE VID_HDR_OFFSET \
- UBINIZE_OPTS UIMAGE_NAME
+ UBINIZE_OPTS UIMAGE_NAME UBINIZE_PARTS
define Device/ExportVar
$(1) : $(2):=$$($(2))