summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/depends.mk2
-rw-r--r--include/toplevel.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/include/depends.mk b/include/depends.mk
index b488af9271..4c31eb3984 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -28,7 +28,7 @@ define rdep
) \
{ \
[ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
- $(SCRIPT_DIR)/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
+ $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
$(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
touch -r "$(2)" "$(2)_check"; \
} \
diff --git a/include/toplevel.mk b/include/toplevel.mk
index dcbcb3eb75..c92686019d 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -52,7 +52,7 @@ prepare-tmpinfo: FORCE
scripts/config/mconf:
@+$(MAKE) -C scripts/config all
-$(call rdep,scripts/config,scripts/config/mconf)
+$(eval $(call rdep,scripts/config,scripts/config/mconf))
scripts/config/conf:
@+$(MAKE) -C scripts/config conf