summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/image.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 8f895a3435..729929f9da 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -87,6 +87,13 @@ define Image/BuildKernel/MkuImageARM
-n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(2) $(3)
endef
+define Image/BuildKernel/MkFIT
+ $(TOPDIR)/scripts/mkits.sh \
+ -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) -d $(3) -C $(4) -a $(5) -e $(6) \
+ -A $(ARCH) -v $(LINUX_VERSION)
+ PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
+endef
+
define Image/mkfs/jffs2/sub
# FIXME: removing this line will cause strange behaviour in the foreach loop below
$(STAGING_DIR_HOST)/bin/mkfs.jffs2 $(3) --pad -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(2) -d $(TARGET_DIR) -v 2>&1 1>/dev/null | awk '/^.+$$$$/'