summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk1
-rw-r--r--include/image.mk3
2 files changed, 3 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 1128aeab6d..fc36509efd 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -107,6 +107,7 @@ define Build/append-ubi
$@.tmp \
-p $(BLOCKSIZE) -m $(PAGESIZE) \
$(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
+ $(if $(VID_HDR_OFFSET),-O $(VID_HDR_OFFSET)) \
$(UBINIZE_OPTS)
cat $@.tmp >> $@
rm $@.tmp
diff --git a/include/image.mk b/include/image.mk
index b24ba1cca7..3891787140 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -295,6 +295,7 @@ define Device/Init
BLOCKSIZE :=
PAGESIZE :=
SUBPAGESIZE :=
+ VID_HDR_OFFSET :=
UBINIZE_OPTS := -E 5
MKUBIFS_OPTS :=
@@ -310,7 +311,7 @@ DEFAULT_DEVICE_VARS := \
DEVICE_NAME KERNEL KERNEL_INITRAMFS KERNEL_INITRAMFS_IMAGE \
DEVICE_DTS DEVICE_DTS_DIR \
UBOOTENV_IN_UBI KERNEL_IN_UBI \
- BLOCKSIZE PAGESIZE SUBPAGESIZE \
+ BLOCKSIZE PAGESIZE SUBPAGESIZE VID_HDR_OFFSET \
UBINIZE_OPTS
define Device/ExportVar