summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/package-defaults.mk1
-rw-r--r--include/package-dumpinfo.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 1d29119d81..1695204b36 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -10,6 +10,7 @@ define Package/Default
SECTION:=opt
CATEGORY:=Extra packages
DEPENDS:=
+ MDEPENDS:=
PROVIDES:=
EXTRA_DEPENDS:=
MAINTAINER:=OpenWrt Developers Team <openwrt-devel@openwrt.org>
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index 34196e4086..3f7a83a979 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -31,6 +31,7 @@ $(if $(MENU),Menu: $(MENU)
)$(if $(findstring $(PREREQ_CHECK),1),Prereq-Check: 1
)Version: $(VERSION)
Depends: $(DEPENDS)
+Menu-Depends: $(MDEPENDS)
Provides: $(PROVIDES)
$(if $(VARIANT),Build-Variant: $(VARIANT)
)$(if $(PKG_BUILD_DEPENDS),Build-Depends: $(PKG_BUILD_DEPENDS)