summaryrefslogtreecommitdiffstats
path: root/include/verbose.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/verbose.mk')
-rw-r--r--include/verbose.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/include/verbose.mk b/include/verbose.mk
index 620dbbd0f9..36e59904ec 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -21,12 +21,12 @@ ifeq ("$(origin V)", "command line")
endif
ifeq ($(IS_TTY),1)
- _Y:="\\033[33m" # yellow
- _N:="\\033[m" #normal
+ _Y:=\\033[33m
+ _N:=\\033[m
endif
define MESSAGE
- /bin/echo -e "$(_Y)$(1)$(_N)" >&3
+ printf "$(_Y)%s$(_N)\n" "$(1)" >&3
endef
ifneq ($(KBUILD_VERBOSE),99)
@@ -37,7 +37,7 @@ ifneq ($(KBUILD_VERBOSE),99)
_DIR:=
endif
_NULL:=$(if $(MAKECMDGOALS),$(shell \
- $(call MESSAGE, "make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)"); \
+ $(call MESSAGE, make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)); \
))
else
ifeq ($(KBUILD_VERBOSE),0)