summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 33baa86da9..d8651d923b 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -166,6 +166,8 @@ clean dirclean: .config
prereq:: prepare-tmpinfo .config
@+$(NO_TRACE_MAKE) -r -s $@
+WARN_PARALLEL_ERROR = $(if $(BUILD_LOG),,$(and $(filter -j,$(MAKEFLAGS)),$(findstring s,$(OPENWRT_VERBOSE))))
+
ifeq ($(SDK),1)
%::
@@ -184,7 +186,10 @@ else
printf "$(_R)WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!$(_N)\n" >&2; \
fi \
)
- @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+ @+$(ULIMIT_FIX) $(SUBMAKE) -r $@ $(if $(WARN_PARALLEL_ERROR), || { \
+ printf "$(_R)Build failed - please re-run with -j1 to see the real error message$(_N)\n" >&2; \
+ false; \
+ } )
endif