summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index d8651d923b..bbeb7ebcef 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -193,6 +193,20 @@ else
endif
+# update all feeds, re-create index files, install symlinks
+package/symlinks:
+ ./scripts/feeds update -a
+ ./scripts/feeds install -a
+
+# re-create index files, install symlinks
+package/symlinks-install:
+ ./scripts/feeds update -i
+ ./scripts/feeds install -a
+
+# remove all symlinks, don't touch ./feeds
+package/symlinks-clean:
+ ./scripts/feeds uninstall -a
+
help:
cat README