summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 0b8a658c18..67357b033a 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -136,13 +136,19 @@ kernel_menuconfig: prepare_kernel_conf
kernel_nconfig: prepare_kernel_conf
$(_SINGLE)$(NO_TRACE_MAKE) -C target/linux nconfig
-tmp/.prereq-build: $(if $(SDK),.git/config) include/prereq-build.mk
+tmp/.prereq-build: include/prereq-build.mk
mkdir -p tmp
rm -f tmp/.host.mk
@$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
echo "Prerequisite check failed. Use FORCE=1 to override."; \
false; \
}
+ ifneq ($(realpath $(TOPDIR)/include/prepare.mk),)
+ @$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prepare.mk prepare 2>/dev/null || { \
+ echo "Preparation failed."; \
+ false; \
+ }
+ endif
touch $@
printdb: FORCE