summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/target.mk b/include/target.mk
index c8eb76c254..1590b91091 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -75,9 +75,11 @@ define Profile
endif
endef
--include $(PLATFORM_DIR)/profiles/*.mk
-ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
- -include $(PLATFORM_SUBDIR)/profiles/*.mk
+ifeq ($(DUMP)$(if $(TARGET_BUILD),,1),)
+ -include $(PLATFORM_DIR)/profiles/*.mk
+ ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ -include $(PLATFORM_SUBDIR)/profiles/*.mk
+ endif
endif
$(eval $(call shexport,Target/Description))