summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/target.mk b/include/target.mk
index d0f7b9bc2b..1718a869c1 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -5,14 +5,16 @@
# See /LICENSE for more information.
#
-include $(TMP_DIR)/.target.mk
define AddProfile
- ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
- PROFILE=$(1)
+ ifeq ($(CONFIG_LINUX_$(1)),y)
+ $(call Profile/$(1))
+ PROFILE=$$(ID)
endif
endef
+include $(TMP_DIR)/.target.mk
+
ifeq ($(IB),1)
$(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
$(CP) $< $@