summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk10
1 files changed, 3 insertions, 7 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 217d6bc376..0a3eff307e 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -37,13 +37,9 @@ endef
# Parameters: <subdir> <name> <target>
define stampfile
$(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
- $(if $(__rdep_$(1)),,
- $(call rdep,$(1),$$($(1)/stamp-$(3)),)
- __rdep_$(1):=1
- )
-
- $$($(1)/stamp-$(3)):
- @+$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
+ $$($(1)/stamp-$(3)): $(TMP_DIR)/.build
+ @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) || \
+ $(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
@mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
@touch $$($(1)/stamp-$(3))