summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 81a6f2a428..fe46ed0de0 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -23,8 +23,6 @@ $(call warn,$(1),$(2),$(3) $(4))
$(4)
endef
-dep/compile=$(1)/prepare
-dep/install=$(1)/compile
SUBTARGETS:=clean download prepare compile install update refresh prereq
# Parameters: <subdir>
@@ -33,7 +31,7 @@ define subdir
$(foreach bd,$($(1)/builddirs),
$(call warn,$(1),d,BD $(1)/$(bd))
$(foreach target,$(SUBTARGETS),
- $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(call dep/$(target),$(1)/$(bd)) $($(1)/$(bd)/$(target)) $($(1)//$(target)))
+ $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
@$$(MAKE) -j1 -C $(1)/$(bd) $(target)
# legacy targets