summaryrefslogtreecommitdiffstats
path: root/include/rootfs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/rootfs.mk')
-rw-r--r--include/rootfs.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index 4b4482c213..90ee312619 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -34,11 +34,11 @@ ifdef CONFIG_USE_MKLIBS
endif
# where to build (and put) .ipk packages
-OPKG:= \
+opkg = \
IPKG_NO_SCRIPT=1 \
- IPKG_INSTROOT=$(TARGET_DIR) \
- $(XARGS) $(STAGING_DIR_HOST)/bin/opkg \
- --offline-root $(TARGET_DIR) \
+ IPKG_INSTROOT=$(1) \
+ $(STAGING_DIR_HOST)/bin/opkg \
+ --offline-root $(1) \
--force-depends \
--force-overwrite \
--force-postinstall \