summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 0d63e62fd2..fbb3e01e35 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -67,7 +67,7 @@ ifneq ($(PKG_BUILD_DIR),)
endif
ifneq ($(HOST_BUILD_DIR),)
- HOST_QUILT?=$(if $(wildcard $(if $(PKG_BUILD_DIR),$(PKG_BUILD_DIR),$(HOST_BUILD_DIR))/.quilt_used),y)
+ HOST_QUILT?=$(if $(findstring command,$(origin $(QUILT))),$(QUILT),$(if $(wildcard $(HOST_BUILD_DIR)/.quilt_used),y))
ifneq ($(HOST_QUILT),)
HOST_STAMP_PATCHED:=$(HOST_BUILD_DIR)/.quilt_patched
HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked