summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 70bc84e4cc..c569231173 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -68,11 +68,8 @@ endef
define Kernel/Patch/Default
rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
- if [ -d $(GENERIC_FILES_DIR) ]; then $(CP) $(GENERIC_FILES_DIR)/* $(LINUX_DIR)/; fi
- if [ -d $(FILES_DIR) ]; then \
- $(CP) $(FILES_DIR)/* $(LINUX_DIR)/; \
- find $(LINUX_DIR)/ -name \*.rej | xargs rm -f; \
- fi
+ $(CP) $(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.) $(LINUX_DIR)/
+ find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
$(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
$(call PatchDir,$(PATCH_DIR),platform/)
endef