summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 0e145c939b..42b624f817 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -71,10 +71,13 @@ $(eval $(call TestHostCommand,zlib, \
echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - $(zlib_link_flags)))
+# Xcode deprecated openssl, MacPorts doesn't work nicely for other packages
+ifneq ($(HOST_OS),Darwin)
$(eval $(call TestHostCommand,libssl, \
Please install the openssl library (with development headers), \
echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
+endif
$(eval $(call TestHostCommand,perl-thread-queue, \
Please install the Perl Thread::Queue module, \
@@ -160,8 +163,10 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))
+ifneq ($(HOST_OS),Darwin)
$(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
openssl version | grep '\(OpenSSL\|LibreSSL\)'))
+endif
# Install ldconfig stub