summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index fbe7d69f44..d6d2d73a63 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -134,3 +134,11 @@ endef
$(eval $(call Require,gnu-find, \
Please install GNU find \
))
+
+define Require/getopt-extended
+ getopt --long - - >/dev/null
+endef
+
+$(eval $(call Require,getopt-extended, \
+ Please install an extended getopt version that supports --long \
+))