summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 211201af3d..f5fb9e270a 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -60,10 +60,16 @@ $(eval $(call TestHostCommand,ncurses, \
echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
+ifeq ($(HOST_OS),Linux)
+ zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic
+else
+ zlib_link_flags := -lz
+endif
+
$(eval $(call TestHostCommand,zlib, \
- Please install zlib. (Missing libz.so or zlib.h), \
+ Please install a static zlib. (Missing libz.a or zlib.h), \
echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
- gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - -lz))
+ gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - $(zlib_link_flags)))
$(eval $(call TestHostCommand,libssl, \
Please install the openssl library (with development headers), \