summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c31020c321..9b77a1baf7 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -119,6 +119,18 @@ $(eval $(call Require,gnutar, \
Please install GNU tar. \
))
+define Require/git
+ which git-clone
+endef
+
+$(eval $(call Require,git, \
+ Please install git. \
+))
+
+$(eval $(call RequireCommand,svn, \
+ Please install the subversion client. \
+))
+
$(eval $(call RequireCommand,autoconf, \
Please install GNU autoconf. \
))