summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk8
1 files changed, 3 insertions, 5 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c7d59f1202..59ea7ef9a7 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -39,6 +39,8 @@ $(eval $(call Require,case-sensitive-fs, \
))
define Require/getopt
+ gnugetopt --help 2>&1 | grep long >/dev/null || \
+ /usr/local/bin/getopt --help 2>&1 | grep long >/dev/null || \
getopt --help 2>&1 | grep long >/dev/null
endef
$(eval $(call Require,getopt, \
@@ -134,15 +136,11 @@ $(eval $(call RequireCommand,bzip2, \
Please install bzip2. \
))
-$(eval $(call RequireCommand,patch, \
- Please install patch. \
-))
-
$(eval $(call RequireCommand,perl, \
Please install perl. \
))
-$(eval $(call RequireCommand,python, \
+$(eval $(call RequireCommand,$(PYTHON), \
Please install python. \
))