summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/package.mk b/include/package.mk
index ff9a5df9e6..092811c2c2 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -167,7 +167,7 @@ define Build/DefaultTargets
)
$(STAMP_PREPARED) : export PATH=$$(TARGET_PATH_PKG)
- $(STAMP_PREPARED):
+ $(STAMP_PREPARED): $(STAMP_PREPARED_DEPENDS)
@-rm -rf $(PKG_BUILD_DIR)
@mkdir -p $(PKG_BUILD_DIR)
$(foreach hook,$(Hooks/Prepare/Pre),$(call $(hook))$(sep))
@@ -176,7 +176,7 @@ define Build/DefaultTargets
touch $$@
$(call Build/Exports,$(STAMP_CONFIGURED))
- $(STAMP_CONFIGURED): $(STAMP_PREPARED)
+ $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(STAMP_CONFIGURED_DEPENDS)
$(CleanStaging)
$(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
$(Build/Configure)
@@ -185,7 +185,7 @@ define Build/DefaultTargets
touch $$@
$(call Build/Exports,$(STAMP_BUILT))
- $(STAMP_BUILT): $(STAMP_CONFIGURED)
+ $(STAMP_BUILT): $(STAMP_CONFIGURED) $(STAMP_BUILT_DEPENDS)
$(foreach hook,$(Hooks/Compile/Pre),$(call $(hook))$(sep))
$(Build/Compile)
$(foreach hook,$(Hooks/Compile/Post),$(call $(hook))$(sep))