summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 01fb4dbd81..d2754abe44 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -167,7 +167,7 @@ $(call KernelPackage/$(1)/config)
$(call KernelPackage/depends)
ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m y,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
- ifneq ($(strip $(FILES)),)
+ ifneq ($(if $(SDK),$(filter-out $(LINUX_DIR)/%.ko,$(FILES)),$(strip $(FILES))),)
define Package/kmod-$(1)/install
@for mod in $$(FILES); do \
if [ -e $$$$$$$$mod ]; then \