summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 20377af3cf..cb62e63810 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -77,6 +77,7 @@ define ModuleAutoLoad
$(3) \
if [ -n "$$$$$$$$modules" ]; then \
mkdir -p $(2)/etc/modules.d; \
+ mkdir -p $(2)/CONTROL; \
echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
echo ". /etc/functions.sh" >> $(2)/CONTROL/postinst; \