summaryrefslogtreecommitdiffstats
path: root/include/kernel-version.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/kernel-version.mk')
-rw-r--r--include/kernel-version.mk14
1 files changed, 6 insertions, 8 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index ee3486fdb1..508cf9934a 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -1,11 +1,9 @@
# Use the default kernel version if the Makefile doesn't override it
-ifeq ($(LINUX_VERSION),)
- ifeq ($(KERNEL),2.4)
- LINUX_VERSION:=2.4.34
- else
- LINUX_VERSION:=2.6.21.5
- endif
+ifeq ($(KERNEL),2.4)
+ LINUX_VERSION?=2.4.34
+else
+ LINUX_VERSION?=2.6.21.5
endif
LINUX_RELEASE?=1
@@ -22,6 +20,6 @@ endif
# disable the md5sum check for unknown kernel versions
LINUX_KERNEL_MD5SUM?=x
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
-KERNEL_PATCHVER:=$(shell echo $(LINUX_VERSION) | cut -d. -f1,2,3 | cut -d- -f1)
+KERNEL?=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
+KERNEL_PATCHVER=$(shell echo $(LINUX_VERSION) | cut -d. -f1,2,3 | cut -d- -f1)