summaryrefslogtreecommitdiffstats
path: root/include/kernel-version.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/kernel-version.mk')
-rw-r--r--include/kernel-version.mk19
1 files changed, 15 insertions, 4 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index eaac886ebb..9a9f1c8bff 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,13 +3,24 @@
ifeq ($(LINUX_VERSION),)
ifeq ($(KERNEL),2.4)
LINUX_VERSION:=2.4.34
- LINUX_RELEASE:=1
- LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
else
LINUX_VERSION:=2.6.21.5
- LINUX_RELEASE:=1
- LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
endif
endif
+LINUX_RELEASE?=1
+
+ifeq ($(LINUX_VERSION),2.4.34)
+ LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
+endif
+ifeq ($(LINUX_VERSION),2.6.22-rc6)
+ LINUX_KERNEL_MD5SUM:=37adac36f3928f5e05dd2704c083620d
+endif
+ifeq ($(LINUX_VERSION),2.6.21.5)
+ LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
+endif
+
+# disable the md5sum check for unknown kernel versions
+LINUX_KERNEL_MD5SUM?=x
+
KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))