summaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk16
1 files changed, 14 insertions, 2 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 06f4ce7726..a3c714c688 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -18,13 +18,25 @@ KERNEL_IPKG:=$(KERNEL_BUILD_DIR)/kernel_$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEAS
TARGETS += $(KERNEL_IPKG)
INSTALL_TARGETS += $(KERNEL_IPKG)
-LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+ifneq (,$(findstring uml,$(BOARD)))
+ LINUX_KARCH:=um
+else
+ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-e 's/mipsel/mips/' \
-e 's/mipseb/mips/' \
-e 's/powerpc/ppc/' \
-e 's/sh[234]/sh/' \
-e 's/armeb/arm/' \
-)
+ )
+endif
+
+KERNELNAME=
+ifneq (,$(findstring x86,$(BOARD)))
+ KERNELNAME="bzImage"
+endif
+ifneq (,$(findstring ppc,$(BOARD)))
+ KERNELNAME="uImage"
+endif
$(TARGETS): $(PACKAGE_DIR)