summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index a1e00df716..bf5f0a6a20 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -327,6 +327,7 @@ define Device/Init
BLOCKSIZE :=
PAGESIZE :=
SUBPAGESIZE :=
+ UBINIZE_OPTS := -E 5
FILESYSTEMS := $(TARGET_FILESYSTEMS)
endef
@@ -334,7 +335,8 @@ endef
DEFAULT_DEVICE_VARS := \
DEVICE_NAME KERNEL KERNEL_INITRAMFS KERNEL_INITRAMFS_IMAGE \
UBOOTENV_IN_UBI KERNEL_IN_UBI \
- BLOCKSIZE PAGESIZE SUBPAGESIZE
+ BLOCKSIZE PAGESIZE SUBPAGESIZE \
+ UBINIZE_OPTS
define Device/ExportVar
$(1) : $(2):=$$($(2))