summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 56c60d6087..73fc805bb5 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -323,6 +323,11 @@ define Build/lzma
@mv $@.new $@
endef
+define Build/gzip
+ gzip -9n -c $@ $(1) > $@.new
+ @mv $@.new $@
+endef
+
define Build/kernel-bin
rm -f $@
cp $^ $@