summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 1b7fd2404a..b8be838313 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -362,6 +362,7 @@ define Device/Check
_COMPILE_TARGET = $$(if $(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES)),compile,compile-disabled)
endef
+ifndef IB
define Device/Build/initramfs
$$(_TARGET): $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)
@@ -373,6 +374,7 @@ define Device/Build/initramfs
@rm -f $$@
$$(call concat_cmd,$$(KERNEL_INITRAMFS))
endef
+endif
define Device/Build/check_size
@[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -gt "$$(stat -c%s $@)" ] || { \