summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 8cf54bbaa1..f95a68dab1 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -151,7 +151,7 @@ endef
define Build/sysupgrade-tar
sh $(TOPDIR)/scripts/sysupgrade-tar.sh \
--board $(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)) \
- --kernel $(word 1,$^) \
- --rootfs $(word 2,$^) \
+ --kernel $(call param_get_default,kernel,$(1),$(word 1,$^)) \
+ --rootfs $(call param_get_default,rootfs,$(1),$(word 2,$^)) \
$@
endef