summaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/host.mk b/include/host.mk
index 8092e8db77..f3e47c8723 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -36,7 +36,7 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
*) HOST_ARCH=`uname -p`;; \
esac; \
GNU_HOST_NAME=`gcc -dumpmachine`; \
- [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" == "Darwin" ] && \
+ [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" = "Darwin" ] && \
GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
echo "HOST_OS:=$$HOST_OS" > $@; \
echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \