summaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/include/host.mk b/include/host.mk
new file mode 100644
index 0000000000..3a5fd9683e
--- /dev/null
+++ b/include/host.mk
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/.host.mk
+
+export TAR
+
+$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
+ @( \
+ HOST_OS=`uname`; \
+ case "$$HOST_OS" in \
+ Linux) HOST_ARCH=`uname -m`;; \
+ *) HOST_ARCH=`uname -p`;; \
+ esac; \
+ GNU_HOST_NAME=`gcc -dumpmachine`; \
+ [ -n "$$GNU_HOST_NAME" ] || \
+ GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+ echo "HOST_OS:=$$HOST_OS" > $@; \
+ echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
+ echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
+ if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
+ echo "TAR_WILDCARDS:=--wildcards" >> $@; \
+ fi; \
+ TAR=`which gtar tar | head -n 1`; \
+ echo "TAR:=$$TAR" >> $@; \
+ )
+