summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index e934c91c66..f4b6b449e1 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -80,7 +80,7 @@ ifneq ($(strip $(PKG_SOURCE)),)
$(STAMP_PREPARED): $(DL_DIR)/$(PKG_SOURCE)
endif
-ifneq ($(CONFIG_AUTOREBUILD),)
+ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
define HostBuild/Autoclean
$(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
$(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
@@ -105,7 +105,6 @@ define HostBuild
$(STAMP_BUILT): $(STAMP_CONFIGURED)
$(call Build/Compile)
- @$(NO_TRACE_MAKE) $(PKG_BUILD_DIR)/.dep_files
touch $$@
$(STAGING_DIR)/stampfiles/.host_$(PKG_NAME)-installed: $(STAMP_BUILT)