summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 811c42a3c3..78848b9c95 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -5,7 +5,7 @@
# See /LICENSE for more information.
#
-DOWNLOAD_RDEP:=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
+DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
# Try to guess the download method from the URL
define dl_method
@@ -132,7 +132,9 @@ define Download
endif
)
- $(if $(DOWNLOAD_RDEP),$(DOWNLOAD_RDEP): $(DL_DIR)/$(FILE))
+ $(foreach dep,$(DOWNLOAD_RDEP),
+ $(dep): $(DL_DIR)/$(FILE)
+ )
download: $(DL_DIR)/$(FILE)
$(DL_DIR)/$(FILE):