summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 74986be598..f064ee9e8c 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -41,7 +41,7 @@ define DownloadMethod/default
endef
define wrap_mirror
- @$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) )
+ $(if $(MIRROR),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) ),$(1))
endef
define DownloadMethod/cvs
@@ -101,6 +101,7 @@ define Download/Defaults
PROTO:=
MD5SUM:=
SUBDIR:=
+ MIRROR:=1
VERSION:=
endef