summaryrefslogtreecommitdiffstats
path: root/include/debug.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/debug.mk')
-rw-r--r--include/debug.mk15
1 files changed, 11 insertions, 4 deletions
diff --git a/include/debug.mk b/include/debug.mk
index 73e6179060..68d70ba093 100644
--- a/include/debug.mk
+++ b/include/debug.mk
@@ -10,12 +10,15 @@
# d: show subdirectory tree
# t: show added targets
# l: show legacy targets
+# r: show autorebuild messages
# v: verbose (no .SILENCE for common targets)
-ifeq ($(DEBUG),all)
- build_debug:=dltv
-else
- build_debug:=$(DEBUG)
+ifeq ($(DUMP),)
+ ifeq ($(DEBUG),all)
+ build_debug:=dltvr
+ else
+ build_debug:=$(DEBUG)
+ endif
endif
define debug
@@ -26,6 +29,10 @@ define warn
$$(if $(call debug,$(1),$(2)),$$(warning $(3)))
endef
+define debug_eval
+$$(if $(call debug,$(1),$(2)),$(3))
+endef
+
define warn_eval
$(call warn,$(1),$(2),$(3) $(4))
$(4)