summaryrefslogtreecommitdiffstats
path: root/include/debug.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/debug.mk')
-rw-r--r--include/debug.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/include/debug.mk b/include/debug.mk
index faead042dc..bec74d187a 100644
--- a/include/debug.mk
+++ b/include/debug.mk
@@ -21,6 +21,8 @@ ifeq ($(DUMP),)
endif
endif
+ifneq ($(DEBUG),)
+
define debug
$$(findstring $(2),$$(if $$(DEBUG_SCOPE_DIR),$$(if $$(filter $$(DEBUG_SCOPE_DIR)%,$(1)),$(build_debug)),$(build_debug)))
endef
@@ -38,4 +40,12 @@ $(call warn,$(1),$(2),$(3) $(4))
$(4)
endef
+else
+
+debug:=
+warn:=
+debug_eval:=
+warn_eval = $(4)
+
+endif