summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 308b45a5f3..4d98a7cd0a 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -32,9 +32,7 @@ define autoreconf
(cd $(1); \
$(patsubst %,rm -f %;,$(2)) \
$(foreach p,$(3), \
- if [ -x $(p)/autogen.sh ]; then \
- $(AM_TOOL_PATHS) $(p)/autogen.sh || true; \
- elif [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
+ if [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
[ -f $(p)/aclocal.m4 ] && [ ! -f $(p)/acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
[ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
$(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \