summaryrefslogtreecommitdiffstats
path: root/docs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile')
-rw-r--r--docs/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/docs/Makefile b/docs/Makefile
index 8c3ca646dd..359f4e6308 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -1,14 +1,23 @@
-openwrt.pdf: Makefile openwrt.tex config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+MAIN = openwrt.tex
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+
+all:
$(MAKE) cleanup
- pdflatex openwrt.tex
- pdflatex openwrt.tex
+ latex $(MAIN)
+ $(MAKE) openwrt.pdf openwrt.html
$(MAKE) cleanup
+
+openwrt.html: $(DEPS)
+ htlatex $(MAIN)
+
+openwrt.pdf: $(DEPS)
+ pdflatex $(MAIN)
clean: cleanup
- rm -f openwrt.pdf
+ rm -f openwrt.pdf openwrt.html openwrt.css
cleanup: FORCE
- rm -f *.log *.aux *.toc *.out
+ rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
FORCE: