summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/package-defaults.mk6
-rw-r--r--include/package-dumpinfo.mk2
2 files changed, 7 insertions, 1 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 75442925f1..c3496767cf 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -5,6 +5,12 @@
# See /LICENSE for more information.
#
+ifneq ($(PKG_NAME),toolchain)
+ PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),+libc $(filter-out +libc,$(2)))
+else
+ PKG_FIXUP_DEPENDS = $(2)
+endif
+
define Package/Default
CONFIGFILE:=
SECTION:=opt
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index a297f2336e..2bf78c3f18 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -30,7 +30,7 @@ $(if $(MENU),Menu: $(MENU)
)$(if $(DEFAULT),Default: $(DEFAULT)
)$(if $(findstring $(PREREQ_CHECK),1),Prereq-Check: 1
)Version: $(VERSION)
-Depends: $(DEPENDS)
+Depends: $(call PKG_FIXUP_DEPENDS,$(1),$(DEPENDS))
Menu-Depends: $(MDEPENDS)
Provides: $(PROVIDES)
$(if $(VARIANT),Build-Variant: $(VARIANT)