summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--include/toplevel.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index e56535eac4..970b0896ca 100644
--- a/Makefile
+++ b/Makefile
@@ -45,10 +45,10 @@ $(BUILD_DIR)/.prepared: Makefile
clean: FORCE
rm -rf $(BUILD_DIR) $(BIN_DIR)
$(MAKE) target/linux/clean
- rm -rf $(TMP_DIR)
dirclean: clean
rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
+ rm -rf $(TMP_DIR)
# check prerequisites before starting to build
prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 7930223650..040ff51249 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -98,7 +98,7 @@ download: .config FORCE
$(MAKE) -j1 package/download
$(MAKE) -j1 target/download
-clean dirclean:
+clean dirclean: .config
@$(MAKE) $@
prereq:: .config