summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile12
-rw-r--r--include/toplevel.mk1
2 files changed, 8 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index b67413b887..e56535eac4 100644
--- a/Makefile
+++ b/Makefile
@@ -9,8 +9,7 @@
TOPDIR:=${CURDIR}
LC_ALL:=C
LANG:=C
-IS_TTY:=${shell tty -s && echo 1 || echo 0}
-export TOPDIR LC_ALL LANG IS_TTY
+export TOPDIR LC_ALL LANG
world:
@@ -31,10 +30,13 @@ else
include tools/Makefile
include toolchain/Makefile
-$(toolchain/stamp-compile): $(tools/stamp-compile)
+$(toolchain/stamp-install): $(tools/stamp-install)
$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
-$(package/stamp-compile): $(target/stamp-compile)
-$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
+$(package/stamp-cleanup): $(target/stamp-compile)
+$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-install): $(package/stamp-compile)
+$(package/stamp-rootfs-prepare): $(package/stamp-install)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
$(BUILD_DIR)/.prepared: Makefile
@mkdir -p $$(dirname $@)
diff --git a/include/toplevel.mk b/include/toplevel.mk
index ba5cb33759..7930223650 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -22,6 +22,7 @@ else
endif
endif
export OPENWRTVERSION
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
ifeq ($(FORCE),)
.config scripts/config/conf scripts/config/mconf: tmp/.prereq-build