summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/prereq-build.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c80e004c0c..2391e098c6 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -121,8 +121,12 @@ $(eval $(call RequireCommand,wget, \
Please install wget. \
))
-$(eval $(call RequireCommand,git, \
- Please install git (git-core). \
+define Require/git
+ git --version | awk '($$$$1 == "git") && ($$$$2 == "version") && ($$$$3 >= "1.6.5") { print "ok" }' | grep ok > /dev/null
+endef
+
+$(eval $(call Require,git, \
+ Please install git (git-core) v1.6.5 or later. \
))
define Require/gnutar