summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in2
-rw-r--r--include/image.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/Config.in b/Config.in
index d6573a6fb7..ea5f8eae2b 100644
--- a/Config.in
+++ b/Config.in
@@ -143,7 +143,7 @@ menu "Target Images"
config TARGET_UBIFS_JOURNAL_SIZE
string
prompt "journal size" if TARGET_ROOTFS_UBIFS
- default "512KiB"
+ default ""
config TARGET_UBIFS_SQUASH_UIDS
bool "squash uids" if TARGET_ROOTFS_UBIFS
diff --git a/include/image.mk b/include/image.mk
index 71822de980..aa565951a9 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -142,7 +142,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_NONE),--force-compr=none) \
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--force-compr=lzo) \
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_ZLIB),--force-compr=zlib) \
- --jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE) \
+ $(if $(shell echo $(CONFIG_TARGET_UBIFS_JOURNAL_SIZE)),--jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE)) \
--squash-uids \
-o $(KDIR)/root.ubifs \
-d $(TARGET_DIR)