summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-kernel.in16
-rw-r--r--include/kernel-defaults.mk2
2 files changed, 18 insertions, 0 deletions
diff --git a/config/Config-kernel.in b/config/Config-kernel.in
index 6e79bae34b..c93bbde511 100644
--- a/config/Config-kernel.in
+++ b/config/Config-kernel.in
@@ -4,6 +4,22 @@
# See /LICENSE for more information.
#
+config KERNEL_BUILD_USER
+ string "Custom Kernel Build User Name"
+ default ""
+ help
+ Sets the Kernel build user string, which for example will be returned
+ by 'uname -a' on running systems.
+ If not set, uses system user at build time.
+
+config KERNEL_BUILD_DOMAIN
+ string "Custom Kernel Build Domain Name"
+ default ""
+ help
+ Sets the Kernel build domain string, which for example will be
+ returned by 'uname -a' on running systems.
+ If not set, uses system hostname at build time.
+
config KERNEL_PRINTK
bool "Enable support for printk"
default y
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 052b2b3a7b..ae02556058 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -10,6 +10,8 @@ KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
CROSS_COMPILE="$(KERNEL_CROSS)" \
ARCH="$(LINUX_KARCH)" \
KBUILD_HAVE_NLS=no \
+ KBUILD_BUILD_USER="$(call qstrip,$(CONFIG_KERNEL_BUILD_USER))" \
+ KBUILD_BUILD_HOST="$(call qstrip,$(CONFIG_KERNEL_BUILD_DOMAIN))" \
CONFIG_SHELL="$(BASH)" \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
$(if $(PKG_BUILD_ID),LDFLAGS_MODULE=--build-id=0x$(PKG_BUILD_ID))