summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk4
-rw-r--r--include/image.mk1
2 files changed, 3 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 8cf54bbaa1..f95a68dab1 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -151,7 +151,7 @@ endef
define Build/sysupgrade-tar
sh $(TOPDIR)/scripts/sysupgrade-tar.sh \
--board $(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)) \
- --kernel $(word 1,$^) \
- --rootfs $(word 2,$^) \
+ --kernel $(call param_get_default,kernel,$(1),$(word 1,$^)) \
+ --rootfs $(call param_get_default,rootfs,$(1),$(word 2,$^)) \
$@
endef
diff --git a/include/image.mk b/include/image.mk
index b5e45ec155..8c3c983c06 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -29,6 +29,7 @@ override NO_TRACE_MAKE:=$(_SINGLE)$(NO_TRACE_MAKE)
target_params = $(subst +,$(space),$*)
param_get = $(patsubst $(1)=%,%,$(filter $(1)=%,$(2)))
+param_get_default = $(firstword $(call param_get,$(1),$(2)) $(3))
param_mangle = $(subst $(space),_,$(strip $(1)))
param_unmangle = $(subst _,$(space),$(1))