summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/prereq-build.mk6
-rw-r--r--include/prereq.mk3
2 files changed, 6 insertions, 3 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 926a06f8ba..3f8f9870b3 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -31,7 +31,8 @@ $(eval $(call SetupHostCommand,gcc, \
gcc49 --version | grep gcc, \
gcc48 --version | grep gcc, \
gcc47 --version | grep gcc, \
- gcc46 --version | grep gcc))
+ gcc46 --version | grep gcc, \
+ gcc --version | grep Apple.LLVM ))
$(eval $(call TestHostCommand,working-gcc, \
Please reinstall the GNU C Compiler - it appears to be broken, \
@@ -45,7 +46,8 @@ $(eval $(call SetupHostCommand,g++, \
g++49 --version | grep g++, \
g++48 --version | grep g++, \
g++47 --version | grep g++, \
- g++46 --version | grep g++))
+ g++46 --version | grep g++, \
+ g++ --version | grep Apple.LLVM ))
$(eval $(call TestHostCommand,working-g++, \
Please reinstall the GNU C++ Compiler - it appears to be broken, \
diff --git a/include/prereq.mk b/include/prereq.mk
index 9bc5e0dee2..71ca96e8a7 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -88,7 +88,8 @@ define SetupHostCommand
define Require/$(1)
for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
$(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
- $(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)); do \
+ $(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \
+ $(call QuoteHostCommand,$(9)); do \
if [ -n "$$$$$$$$cmd" ]; then \
bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
which "$$$$$$$${cmd%% *}")"; \